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EasyScope Overview 
The EasyScope software utility is provided to connect your WaveAce series oscilloscope to your PC. The 
EasyScope application lets you view waveforms, waveform data, waveform measurements, and bitmap images of 
your waveforms. You can also upload/download oscilloscope settings. You can connect your WaveAce series 
oscilloscope to your PC using the USB serial interface or RS-232 interface. 
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Installing EasyScope 
The EasyScope software provides an easy-to-use Wizard. Simply run the SETUP.EXE file and follow the on-
screen instructions. The wizard creates a new program group, installs the files and drivers, and puts an icon on 
your desktop. 

1. Insert the installation CD into the CD-ROM drive. 
2. Double-click EasyScope3.0→Set up→SETUP.EXE to start the EasyScope 3.0 Setup Wizard.  

 

3. Click Next to select an installation folder. 
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4. Click Next to use the default installation folder. The Confirm Installation window opens. 

Note: If you want to install EasyScope 3.0 to a different folder, click the Browse button and choose a 

location. 

5. Click Next to start the installation. 
6. When the installation is complete, a confirmation message is displayed. Click Close to exit the EasyScope 

installation. 

  

Installing the USB Driver 

If you connect your WaveAce series oscilloscope by the USB interface, you need to install the USB driver. If you 
connect your WaveAce series oscilloscope by RS-232 interface, you do not need to install a device driver. 

1. Connect the oscilloscope to your PC using the USB serial cable. Microsoft Windows automatically detects 
the oscilloscope and display the Found New Hardware window. 

2. Click the Found New Hardware window. The Found New Hardware Wizard opens. 
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3. Choose Install from a list or specific location (Advanced) and click Next. The Please choose your 
search and installation options window opens. 
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4. Choose Include this location in the search and click Browse to locate the EasyScope3.0→USB Driver 
folder and then click Next. The USB Driver will be installed. 

5. Click Finish to close the wizard. 

Uninstalling EasyScope 

You can uninstall EasyScope using Add/Remove Programs in the Microsoft Windows Control Panel. 

1. To open Add/Remove Programs, click Start→Control Panel and then double-click Add/Remove 
Programs. 

2. Click Change or Remove Programs, and then click EasyScope3.0. 
3. To remove EasyScope, click Remove. 
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Getting Started with EasyScope 
Once you have installed the EasyScope application, make sure your oscilloscope is connected to your PC. 

Double-click the EasyScope iconon your desktop.  The EasyScope main window opens. 

 

Make sure your oscilloscope is connected to your PC. Turn on your oscilloscope. The left Link Status indicator 
light should be displayed green. 

Click the Connect button on the toolbar.  The Link Status indicator lights in the upper right corner both 
display green to indicate that the oscilloscope was successfully connected. 

  

Getting to Know EasyScope 

The EasyScope screen is divided into these main sections: 

 Menu Bar 

 Toolbar  

 Base Control Panel 

 Data/Graph Display Area 

 Status Bar 

Menu Bar 

The top of the screen contains a menu bar of commonly used functions.  

 

There are four menus: 

 Panel(P) - Provides menu options for connecting/disconnecting your oscilloscope using EasyScope and 
exiting the application. 

 View(V) - Provides menu options to view/hide the Toolbar, Status Bar, and Base Control Panel. 

 Setting(S) - Provides menu options to define EasyScope settings, such as connection settings. 

 Help(H) - Provides information about your EasyScope software. 

 Link Status Indicator - Indicates whether the link between the PC and the oscilloscope is normal and 
whether EasyScope and the oscilloscope are communicating. The left indicator turns green when a the PC 
and the oscilloscope are connecting and it turns red when the link is disconnected. The right indicator turns 
green when the oscilloscope and EasyScope are communicating data and it turns red when they stop data 
communication. 

Note: You can quickly access a menu by clicking the Alt button and the keyboard shortcut for that menu. For 
example, to quickly access the View menu, press Alt + v. 
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Toolbar 

The Toolbar lets you quickly access EasyScope functions. 

 

 Press Connect to connect to your oscilloscope (this is the same as choosing Panel→Connect from the 
menu bar). 

 Press Disc to disconnect your oscilloscope (this is the same as choosing Panel→Disconnect from the 
menu bar). 

 Press Exit to exist the EasyScope application (this is the same as choosing Panel→Exit from the menu 
bar). 

 Press Sidebar to turn the Base Control Panel On or Off (this is the same as choosing View→Base 
Control Panel from the menu bar). 

 Press Panel to display the Virtual Panel. You can operate the oscilloscope using the Virtual Panel. 

 Press About to display information about your EasyScope software (this is the same as choosing 
Help→About EasyScope from the menu bar). 

Base Control Panel 

The Base Control Panel is divided into three areas: 

 Goto View 

 Open Files 

 Device Setting Oper 

 

 Wave Graph - displays up to seven 
waveforms at the same time in the 
Graph Display Area. 

 Wave Data - displays data for up to 
seven waveforms. 

 Wave Measure - displays waveform 
measurement values for up to seven 
waveforms. 

 DSO Bitmap - displays a bitmap image 
of a waveform in the display area. 

 

 Graph file - click this button to recall 
saved waveform graph files. 

 Data file - click this button to recall 
saved waveform data files. 

 Measure file - click this button to recall 
saved waveform measurement value 
files. 

 Bitmap file - click this button to recall 
saved bitmap image files. 

 

 Upload - uploads settings to your 
oscilloscope 

 Download - downloads setting from your 
oscilloscope 
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Status Bar 

 

1. Current operation 
2. Communication status 
3. Link status or oscilloscope model 
4. Current Date 
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Wave Graphs 
You can use the Wave Graph function to view waveforms. 

 

1. Graph Oper - lets you save, copy, open, and print waveform graphs. 
2. Refresh Oper - lets you obtain and display waveform graphs. 
3. Graph Show - lets you indicate the channels you want to display in the Graph display area. 
4. Graph Display - displays the waveform graph(s). 
5. Parameters - displays the waveform parameters for the selected channels, such as Sec/div, Horizontal 

position, Volts/div, Vertical Position, and Trigger Level. 

Displaying WaveGraphs 

When displaying waveform graphs, there are two modes: Auto and Manual. Auto mode automatically refreshes 
the waveform and parameter data using the Refresh Rate setting. Manual mode, the default mode, the 
waveform graph and data are refreshed once each time you press the Refresh button. 

PLEASE NOTE THE FOLLOWING: 

 If you use Auto mode, do not press the RUN/STOP front panel or Virtual Panel button. When you stop the 
acquisition, EasyScope will not be able to automatically refresh. 

 If you want to change the Refresh Rate for Auto mode, make sure you set the display mode to Manual. 
Then, change the Refresh Rate and set it to Auto mode. 

1. To display waveform graphs, click the Wave Graph button on the Base Control Panel. 
2. Click GetAllData. 
3. If you want to automatically refresh the waveform, click Auto. 

 
OR 
 
If you want to manual refresh the waveform, click Manual. 

4. To display waveform measurements in the parameter table below the graph, click CH1 and/or CH2.  
5. Choose the channels you want to display in the Graph Show area. The channels you selected are 

displayed in the Graph display area 
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6. Click the Refresh button. 

Note: When you choose Manual refresh mode, you must click the Refresh button to refresh the display. In Auto 

refresh mode, the waveform is automatically refreshed. 

Opening Waveform Graphs 

You can open saved waveform graph files by clicking the Open button in the Graph Oper area or by clicking the 
button next to Graph File in the Open Files area. An Open File window is displayed. Select the file you want to 
open and click OK. 

Copying Waveform Graphs 

You can copy waveform graphs quickly by clicking Copy in the Graph Oper area. This takes a screen print of the 
wave graph so you can paste it in another application. 

Printing Waveform Graphs 

You can print the wave graph data by clicking the Print button in the Graph Oper area. When you click Print, a 

print preview of the wave graph data is displayed. 

 

To print the wave graph data click the Print toolbar button. 
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Saving Waveform Graphs 

1. You can save the waveform graph data by clicking the Save button in the Graph Oper area. The Select 
the Channel window opens. 

 

2. Select a channel and click OK. 
3. In the Save Graph window, click Browse to choose a location for the saved file. Type a filename and click 

OK to save the data. 

The wave graph data is saved as a comma separated file (.csv). You can then open this file in other programs, 
such as Microsoft Excel. 
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Wave Data 
You can use the Wave Data function to obtain and display waveform data. To display waveform data, click the 
Wave Data button. 

 

Copying Wave Data 

You can copy waveform data quickly by clicking the Copy button at the top of the window. This takes a screen 

print of the wave data so you can paste it in another application. 

Printing Wave Data 

To print the wave data click the Print button at the top of the wave data window. The Select the list item to print 

window opens. 

 

Type a starting and ending item in the list that you want to print and click OK. A print preview of the wave data is 

displayed. 
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To print the wave data, click the Print toolbar button. 

Saving Wave Data 

1. You can save the waveform data by clicking the Save button at the top of the window. The Select the 
Channel window opens. 

 

2. Select a channel and click OK. 
3. In the Save Data window, click Browse to choose a location for the saved file. Type a filename and click 

OK to save the data. 

The wave data is saved as a wave data file (.wdf).  

Note: You can open a wave data file (.wdf) using the Data File... button in the Open Files area. 
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Wave Measurements 
The WaveAce series oscilloscope can automatically measure 32 parameters. Once you have a waveform graph 
displayed, you can view its' waveform measurements. You can copy, print, and save the waveform 
measurements. You can also set Pass/Fail ranges for each measurement. 

Note: You should use Auto mode when displaying waveform graphs to display waveform measurement values. 

To display waveform measurements, click the Wave Measure button.  

 

Copying Wave Measurements 

You can copy waveform measurements quickly by clicking the Copy button at the top of the Wave Measure 

window. This takes a screen print of the wave measurements so you can paste them in another application. 

Printing Wave Measurements 

You can print the wave measurement data by clicking the Print button at the top of the window. When you click 
Print, a print preview of the wave measurement data is displayed. 



WaveAce 

18 ES-OM-E-RevA 

 

Click the Print button on the toolbar to print the waveform measurements. 

Saving Wave Measurements 

  

1. You can save the waveform measurements by clicking the Save button at the top of the window. The 
Select the Channel window opens. 

 

2. Select a channel and click OK. 
3. In the Save Data window, click Browse to choose a location for the saved file. Type a filename and click 

OK to save the data. 

The wave data is saved as a waveform measurement file (.wmf).  

Note: You can open a wave measurement file (.wmf) using the Data File... button in the Open Files area. 
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Setting Pass/Fail Ranges  

The WaveAce series oscilloscope can automatically measure 32 parameters. You can set the Pass/Fail ranges 
for each of these measurements. 

1. To set pass/fail ranges, in the Wave Measure window click the Pass/Fail button. The Pass/Fail setting 
window opens. 

 

2. Click the drop-down arrow to select a measure type, such as Vpp, Vmax, Vmin, etc. and click the Enable 
checkbox. 

3. Under Pass Range Settings, type a minimum and maximum limit.  

Note: The limits must be between -999 and 999. 

2. Click OK. 
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DSO Bitmaps 
Displaying Bitmap Images 

You can use the DSO Bitmap function to display a bitmap (.bmp) image of the current waveform in the display 
area. Once you have displayed a bitmap image, you can copy, print, and save it. 

 

Click Refresh to display a bitmap image of the current waveform. 
 
OR 
 
Click Open to open a previously saved bitmap image file (.bmp). 

Copying Bitmap Images 

You can copy bitmap images quickly by clicking the Copy button at the top of the DSO Bitmap window. This takes 
a screen print of the image so you can paste it in another application. 

Printing Bitmap Images 

To print the bitmap image click the Print button at the top of the window. When you click Print, a print preview of 

the image is displayed. 
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To print the bitmap image, click the Print toolbar button. 

Saving Bitmap Images 

1. You can save the waveform bitmap image by clicking the Save button at the top of the window.  
2. In the Save Bmp file window, click Browse to choose a location for the saved file. Type a filename and 

click OK to save the data. 

The image is saved as a bitmap file (.bmp).  

Note: You can open a previously saved bitmap image file (.bmp) using the DSO Bitmap... button in the Open 
Files area. 
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Device Settings 
Transferring Device Settings 

You can transfer the oscilloscope's settings to your PC and save it for use at another time. You can also 
download the oscilloscope setup data from a saved scope setting file to the oscilloscope. 

 

Uploading Device Settings to your PC 
1. In the Device Setting Oper area, click the Upload button. The current oscilloscope settings are uploaded 

to your PC and a default filename is listed in the Current file field. 
2. If you want to save the uploaded settings, click Save to save settings to the default scope setting file (.ssf) 

listed in the Current file field. 
 
OR 
Click Save As to select a location and enter a new filename for the scope setting file. 

Downloading Device Settings to your Oscilloscope 
1. In the Device Setting Oper area, click the Open button. 
2. In the Open Setting File window, locate the scope setting file (.ssf) you want to download and click OK. 

The scope setting file you chose is listed in the Current file field. 
3. Click the Download button. The scope settings are downloaded to your oscilloscope. 
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Virtual Panel 
Using the Virual Panel 

You can use the EasyScope Virtual Panel to control your oscilloscope using your PC. The Virtual Panel is 
arranged to be the same as your Front Panel Controls on your WaveAce oscilloscope. 

To access the Virtual Panel, click the Panel toolbar button.  

The Virtual Panel is displayed. 

 

Intensity/Adjust Knob 

 

 Intensity/Adjust knob - You can use the Adjust knob with many functions, such as adjusting the holdoff 
time, moving cursors, setting the pulse width, setting the video lineage adjusting the upper and lower 
frequency limits, adjusting X and Y masks when using the Pass/Fail function, etc. You can also use the 
Adjust knob to adjust the storage position of setups, waveforms, pictures when saving/recalling and to 
select menu options. Click the left/right arrow buttons to "turn" the knob. 
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Menu Control Buttons 

 

 Menu Option buttons (1-5) - Press to choose menu options. Press a menu option button adjacent to your 
selection. 

Menu Function Buttons 

 

 CURSORS - Press to turn on the cursors and display the Cursor menu. You can use the Cursor menu to 
set the Cursor Mode (Auto, Off, Manual, Track). When Cursors are on (CURSORS button is lit), press the 
left/right arrow buttons to "turn" the Adjust knob to position the cursors.  

 ACQUIRE - Press to display Acquire menu. You can use the Acquire menu to set the acquisition 
Sampling Mode (Sampling, Peak Detect, Average). 

 SAVE/RECALL - Press to display the Save/Recall menu. You can use the Save/Recall menu to save and 
recall up to 20 scope setups or waveforms in internal memory (up to 20 waveforms) or on a USB memory 
device (limited by memory capacity of USB device). You can also use it to recall the default factory 
settings, to save waveform data as a comma-delimited file (.CSV), and to save or print the displayed 
waveform image. 

 MEASURE - Press to display a menu of measurement parameters. The Display Type must be set to YT 
mode.  

 DISPLAY - Press to open the Display menu. You can use the Display menu to set grid and waveform 
display styles, and persistence. 

 UTILITY - Press to open the Utility menu. You can use the Utility menu to configure WaveAce features, 
such as sound, language, counter, etc. You can also view system status and update software. 

General Control Buttons 

 

 DEFAULT SETUP - Press to reset the oscilloscope's settings to the default factory configuration. For a list 
of default settings, see your WaveAce Getting Started Manual. 
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Run Control Buttons 

 

 SINGLE - Press to acquire a single waveform. Each time you press the SINGLE button, the oscilloscope 
acquires another waveform. When the oscilloscope detects a trigger it completes the acquisition and stops. 

 RUN/STOP - Press when you want the oscilloscope to acquire waveforms continuously. Press RUN/STOP 
again to stop the acquisition. 

 AUTO - Press to have the oscilloscope automatically identify the type of waveform and adjust the controls 
to produce a usable display of the input signal. When you press the AUTO front panel button, the Auto Set 
menu opens. You can use this menu to display multiple-cycle signals, a single-cycle signal, the rising edge, 
the falling edge or recall the previous setup. 

Vertical Controls 

 

 Volts/Div knobs (CH1/CH2)- Click the left/right arrow buttons to "turn" the Volts/Div knob to adjust the 
volts/division setting (vertical gain) of the corresponding channel (CH1 or CH2). Press the knob to toggle 
between fine (variable) and coarse (fixed) adjustments. 

 Channel buttons (CH1/CH2) - Press a channel button (CH1 or CH2) to turn that channel ON or OFF and 
open the Channel menu for that channel. You can use the Channel menu to set up a channel. When the 
channel is ON, the channel button is lit. 

 Vertical Position knobs (CH1/CH2) - Click the left/right arrow buttons to "turn" the Vertical Position knob 
to adjust the vertical position of the corresponding channel (CH1 or CH2). Press to set the vertical position 
to zero. 

 MATH - Press to display the Math menu. You can use the Math menu to use the oscilloscopes Math 
functions. 

 REF - Press to display the Ref Wave menu. You can use this menu to save and recall two reference 
waveforms (REFA and REFB) in internal memory.  
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Horizontal Controls 

 

 Horizontal Position knob - Click the left/right arrow buttons to "turn" the Horizontal Position knob to adjust 
the horizontal position of all channels and math waveforms (the position of the trigger relative to the center 
of the screen). The resolution of this control varies depending on the timebase setting. Press to set the 
horizontal position to zero. 

 HORI MENU - Press to display the Horizontal menu. You can use the Horizontal menu to display the 
waveform and to zoom a segment of a waveform. 

 Time/Div knob - Click the left/right arrow buttons to "turn" the Time/Div knob to change the horizontal time 
scale to magnify or compress the waveform. When Window Zone is enables, it changes the width of the 
Window Zone by changing the window timebase. When Time/Div control is set to 100 ms/div or slower and 
the trigger mode is set to Auto, the oscilloscope enters the scan acquisition mode. In this mode, the 
waveform display updates from left to right. There is no trigger or horizontal position control of waveforms 
during scan mode. 

Trigger Controls 

 

 TRIG MENU - Press to display the Trigger menu. You can use the Trigger menu to set the trigger type 
(Edge, Pulse, Video, Slope, Alternative) and trigger settings. 

 FORCE - Press to complete the current waveform acquisition whether the oscilloscope detects a trigger or 
not. This is useful for SINGLE acquisitions and Normal trigger mode. 

 SET TO 50% - Press to stabilize a waveform quickly. The oscilloscope can set the Trigger Level to be 
halfway between the minimum and maximum voltage levels automatically. This is useful when you connect 
a signal to the EXT TRIG connector and set the trigger source to Ext or Ext/5. 

 LEVEL - Press the left/right arrows to select the trigger threshold level.  

Virtual Panel Controls 
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 Refresh - Press to refresh the data. 

 Close - Press to close the Virtual Panel. 

Knob Controls 

 

 Knob Scale - Displays the knob scale when you press the left/right Adjust knob arrows. 

 Knob Done - Press Knob Done when you want to apply the knob scale setting. 
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Exiting EasyScope 
Disconnecting and Exiting EasyScope 

Before you can exit the EasyScope application, you must first disconnect the oscilloscope.  

Disconnecting the Oscilloscope 

To disconnect, click the Disc toolbar button  or choose Panel→Disconnect from the menu bar. The right 
Link Status indicator light will turn red when the oscilloscope is no longer communicating with EasyScope. 

Exiting EasyScope 

To exit EasyScope, click the Exit toolbar button  or choose Panel→Exit from the menu bar. 


